백준 알고리즘 | 10952번 문제: A+B - 5

출처

https://www.acmicpc.net/problem/10952

문제

두 정수 A와 B를 입력받은 다음, A+B를 출력하는 프로그램을 작성하시오.

입력

입력은 여러 개의 테스트 케이스로 이루어져 있다.
각 테스트 케이스는 한 줄로 이루어져 있으며, 각 줄에 A와 B가 주어진다. (0 < A, B < 10)
입력의 마지막에는 0 두 개가 들어온다.

출력

각 테스트 케이스마다 A+B를 출력한다.

예제 입력 1

1 1 2 3 3 4 9 8 5 2 0 0

예제 출력 1

2 5 7 17 7

알고리즘 분류

  • 수학
  • 구현
  • 사칙연산

문제 풀이

import java.io.*;

public class Main {

    public static void main(String[] args) throws IOException {
        try (
                BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
                BufferedWriter bw = new BufferedWriter(new OutputStreamWriter(System.out));
        ) {
            while (true) {
                // 합치는 값을 받는다.
                String[] input = br.readLine().split(" ");
                final int a = Integer.parseInt(input[0]);
                final int b = Integer.parseInt(input[1]);

                if(a == 0 && b == 0) {
                    break;
                }
                bw.write((a + b) + "\n");
            }

            // 값 출력
            bw.flush();
        }
    }
}



최종 수정 : 2022-04-07